Visual Studio Community 2022 won’t launch (Could not start visual studio due to an error. StreamJsonRpc.RemotelnvocationException: Configuration system failed to initialize (Errorkind: Error Result: 80131500))

This problem began when I tried to launch VS Community after shutting off my PC the previous night. VS Would launch and then use a lot of power (as seen on task manager) then crash. I tried repairing the installation twice, reinstalling, booting in safe mode, and other debugging methods (including renaming and deleting the contents of C:\Users<user>\AppData\Local\Microsoft\VSCommon\OnlineLicensing) but to no avail. Now unlike when this problem began VS won’t even launch in the first place, giving an error (pic attached). I have attatched the most recent log file generated: ActivityLog.xml. My guess is that some file(s) corrupted because I didn’t close VS before shutting off my pc. Doing devenv.exe /resetsettings makes it run for a second before ultimately crashing, just as it did this afternoon when I first noticed the issueUser's image

Read more here: Source link