Solved: Re: Monitoring a Node.js web app running in GCP Cloud Run

In case anyone else runs into the scenario we encountered the following is what resolved the issue for us.

Original Error
ERROR: ld.so: object ‘/opt/dynatrace/oneagent/nonprod/agent/lib64/liboneagentproc.so
2025-06-10T18:15:14.153350Z’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

Resolution

Our application was using Cloud Run execution env V2 which has a CPU architecture type of x86.

Specifying the arch type when retrieving the Dynatrace OneAgent resolved the issue.

$DT_ENV_FQDN/api/v1/deployment/installer/agent/unix/paas/latest?

flavor=default&include=java&arch=x86cc: @Aymeric_M 

 

Read more here: Source link