python 3.x – tensorflow>2.0 unavailable on conda-forge

I am attempting to create an environment from the github repostitory for CityNet, github.com/mdfirman/CityNet, but consistently get the following error:

ResolvePackageNotFound:tensorflow=2.4.1

I am using a miniforge terminal. My machine does not have anaconda installed.

Here is the environment file:

name: citynet
channels:

  • default
  • conda-forge
    dependencies:
  • python=3.6
  • numpy=1.19.5
  • tensorflow=2.4.1
  • pip
  • pip:
    • pyyaml
    • tqdm==4.57.0
    • librosa==0.8.1
    • tf_slim==1.1.0
    • matplotlib==3.3.4

I have python 3.6 and python 3.10.12 installed. I am new-ish to python so please let me know what useful information I have not included.

I have tried using different versions of tensorflow and even forcing conda-forge like this:

conda-forge::tensorflow>=2.0,<=2.10

I attempted to install tensorflow and successfully did but it was in the pypi channel (tensorflow=2.15.0).

Read more here: Source link