google cloud platform – GCP CloudFunctions “no available instance” error – will it be retried?

We run a Cloud Function in production and every so often we get this error:

“The request was aborted because there was no available instance.”

This results in an HTTP 500 error response.

This is a known issue, and the cause seems to be that our traffic is scaling up very quickly and there are not enough function instances to handle the traffic.

This is an event-driven function. According to this documentation:

Cloud Functions guarantees at-least-once execution of an event-driven function for each event emitted by an event source. However, by default, if a function invocation terminates with an error, the function will not be invoked again, and the event will be dropped.

My question is: will my function be retried when I get the error above? The documentation is confusing. Technically, we’re getting an HTTP POST 500 error, so I don’t know whether this function is being retried.

Read more here: Source link