Sporadic XRUNS / Linux – Page 4 – Bitwig Forum

I think I’m having this issue too, but don’t quite have the technical knowledge to know for sure. Any help would be appreciated.

I put together a new system, dual booting Linux Mint Cinnamon and Windows 11 (each OS on its own separate physical drive, system info below). I’m not having any “Xrun” issues with Bitwig on Windows, but I am on Linux. Turning off sandboxing as mentioned in this thread improved things significantly, but for me it didn’t eliminate Xruns. The odd thing about these Xruns is they don’t seem to really correlate with the amount of complexity/polyphony being played, it just seems kind of random (but only happens when playing something). according to System Monitor I’m barely using any CPU, between 2% and 5% when the Xruns happen. I noticed that something called “Gecko” that Firefox uses periodically caused Xruns while also using Bitwig, so closing Firefox improved things a bit more. But there are still these occasional Xruns that are pretty mysterious. I need to completely eliminate Xruns for live performance.

I’m running Pianoteq inside Bitwig, but if I run Pianoteq on its own, I don’t get any Xruns at all, no matter if Firefox or anything else is running.

I tried increasing JACK’s buffer/latency, but it didn’t make any difference. However, I then increased it to a ridiculously huge latency…but the actual latency didn’t change, it still feels perfectly responsive. I then opened Pianoteq on its own and tried to adjust the latency there, but it’s locked in at 64 samples (supposedly 1.3 ms). So it seems like JACK isn’t actually using the settings I made, but possibly locking the buffer extremely low. Bitwig doesn’t show what JACK’s buffer is set to (grayed out fields).

My audio interface is a Native Instruments Komplete Audio One. Maybe it’s setting the buffer and Jack can’t control it? I don’t know if there’s a way (in Linux Mint) to interact with the Komplete Audio One directly. Any ideas?

So anyway, not sure if this could be related to the issue of this thread, but it was the closest thing I’ve come across, especially since turning off sandboxing made a huge improvement. And likewise, it doesn’t matter if I’m using JACK or ALSA. I installed the low-latency kernel, configured real-time access, installed QJackCTL, and Ubuntu Studio Controls (set to “performance” with a2jmidid disabled). Running the latest stable version of Bitwig.

Linux Mint 20.2 Cinnamon (v. 5.0.6)
Kernel 5.11.20-051120-generic
Ryzen 5600X
16 GB Ram
AMD RX 580 graphics card

Read more here: Source link