Migrate to AWS-SDK v3? – Awslabs/Aws-Mobile-Appsync-Sdk-Js

What is the current behavior?
These packages depend on an obsolete monolithic version of the aws sdk (^2.814.0). This drags in a bunch of bloat.

What is the expected behavior?
Depend on just the slice of the v3 aws-sdk required by the package.

It doesn’t look like the project is using all that much from aws-sdk:

  • import { Credentials, CredentialsOptions } from 'aws-sdk/lib/credentials';
  • crypto = require('aws-sdk/global').util.crypto; // just using createHash and createHmac
  • import * as S3 from 'aws-sdk/clients/s3';

I’d be happy to create a pull request for the upgrate if the maintainers are amenable to the change.

Read more here: Source link