c# – Unity3D – Error: The minSdk version can not be specified in the AndroidManifest.xml file. You have to remove it

Build Error appears in Pop Up.

Gradle Error: MinSDK in Manifest

The minSdk version can not be specified in the AndroidManifest.xml file. You have to remove it.
(See the Console for details)

Build Errors appear in console

> Configure project :launcher
WARNING: The option 'android.enableR8' is deprecated and should not be used anymore.
It will be removed in a future version of the Android Gradle plugin, and will no longer allow you to disable R8.



Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF-8

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':launcher:lintVitalRelease'.



UnityEditor.BuildPlayerWindow+BuildMethodException: 4 errors
  at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (UnityEditor.BuildPlayerOptions options) [0x002be] in /Users/bokken/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:190 
  at UnityEditor.BuildPlayerWindow.CallBuildMethods (System.Boolean askForBuildLocation, UnityEditor.BuildOptions defaultBuildOptions) [0x00080] in /Users/bokken/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:95 
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&) (at /Users/bokken/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:189)

Picture of some errors I couldn’t copy.
Console errors, click to view

in essence:
I have tried reinstalling/Updating JAVA.
I have tried removing minsdk line from AndroidManifext.xml
I have tried all possible solutions available on internet but remained with same error.
Please Help to resolve this I want the build.

AndroidManifest.xml File

<?xml version="1.0" encoding="utf-8"?>

<!--
   WARNING: Do NOT modify! Generated file.
-->

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="__AndroidManifest_Package__"
    android:versionCode="__AndroidManifest_VersionCode__"
    android:versionName="__AndroidManifest_VersionName__">
    
    <uses-sdk 
   
        android:targetSdkVersion="__AndroidManifest_TargetSdkVersion__"/>

</manifest>

Source link